読者です 読者をやめる 読者になる 読者になる

無趣味な人

生まれてこの方、無趣味。ハマったものこれといって特になし。

ADTのアップデートでエラー

アプリ開発 PC周りや開発環境に関する小技

AndroidのSDKをアップデートしたら、プロジェクトがエラーだらけになってしまった。 Eclipseを起動するときに、

Error Message : This Android SDK requires Android Developer Toolkit version 22.6.1 or above

というダイアログが表示される。 アップデートしてみることにした。

メニューのHelpから「Install New Software」を選択。 プルダウンから、

Android Developer Tools Update Site - http://dl-ssl.google.com/android/eclipse/

を選択。 Developer Toolsにチェックをしてインストールを開始した。 が、途中でエラーになってしまう。

An error occurred while collecting items to be installed

というダイアログが出てきて、アップデート出来ない。 プロジェクトはエラーだらけだし途方にくれていたら回避方法があった。 ここ

メニューのHelpから「Install New Software」を選択。 プルダウンから選ばず、以下をはりつける。

https://dl-ssl.google.com/android/eclipse/

そして、Addボタンを押す。 以降は流れに任せる。 これでアップデート出来た。プロジェクトのエラーもなくなった。